القائمة الرئيسية

الصفحات

دورة CCNA 200-301 - الدرس التاسع والعشرون (عملية الـ Trunking في سويشات سيسكو)

دورة CCNA 200-301 - الدرس التاسع والعشرون (عملية الـ Trunking في سويشات سيسكو)

دورة CCNA 200-301 - الدرس التاسع والعشرون (عملية الـ Trunking في سويشات سيسكو)

يلزم وجود ترنك لنقل حركة مرور VLAN من سويش إلى آخر. سأشرح في هذا الدرس كيفية تكوين قناة اتصال بين سويشات Cisco Catalyst. دعني أوضح لك الهيكل الذي سنستخدمه:

اثنين من مفاتيح سيسكو


أعلاه ترى طبولوجيا بجهاز كمبيوتر متصل بكل سويش . سنضع أجهزة الكمبيوتر في نفس شبكة VLAN وننشئ قناة اتصال بين السويشين.



لنبدأ بإنشاء شبكة محلية ظاهرية:

SW1(config)#vlan 50
SW1(config-vlan)#name Computers
SW1(config-vlan)#exit
SW2(config)#vlan 50
SW2(config-vlan)#name Computers
SW2(config-vlan)#exit


ودعنا نضع الوصلات المتصلة بأجهزة الكمبيوتر في شبكة VLAN الصحيحة:

SW1(config)#interface fa0/1
SW1(config-if)#switchport access vlan 50
SW2(config)#interface fa0/2
SW2(config-if)#switchport access vlan 50


الخطوة التالية هي إنشاء ترنك بين السويشين . من الناحية الفنية ، يمكن أيضًا أن تكون الوصلات بين السويشين في وضع access لأن لدينا شبكة محلية ظاهرية واحدة فقط.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.


أحاول تغيير الوصلة إلى وضع trunk باستخدام الأمر switchport mode trunk. اعتمادًا على طراز السويش ، قد ترى نفس الخطأ . إذا أردنا تغيير الوصلة إلى وضع trunk ، فنحن بحاجة إلى تغيير نوع التغليف. دعونا نرى ما هي الخيارات المتوفرة لدينا:

SW1(config-if)#switchport trunk encapsulation ?
  dot1q      Interface uses only 802.1q trunking encapsulation when trunking
  isl        Interface uses only ISL trunking encapsulation when trunking
  negotiate  Device will negotiate trunking encapsulation with peer on interface


هذا هو المكان الذي يمكنك فيه الاختيار بين 802.1Q أو تغليف ISL. بشكل افتراضي ، سيتفاوض السويشان حول نوع التغليف.

SW1(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport trunk encapsulation dot1q


لنقم بتغييره إلى 802.1Q باستخدام الأمر switchport trunk encapsulation.

SW1#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic auto 
Operational Mode: static access 
Administrative Trunking Encapsulation: dot1q
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic auto 
Operational Mode: static access 
Administrative Trunking Encapsulation: dot1q


كما ترى فإن بروتوكول التغليف أصبح الآن 802.1Q.

SW1(config)#interface fa0/14
SW1(config-if)#switchport mode trunk
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode trunk

الآن يمكنني تغيير وضع switchport إلى trunk بنجاح.

SW1#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled Administrative Mode: trunk Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled Administrative Mode: trunk Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q

يمكننا أن نؤكد أن الـ trunk يعمل لأن وضع التشغيل هو "dot1q".


لنجرب ما إذا كان بإمكان H1 و H2 الوصول إلى بعضهما البعض:

C:\Documents and Settings\H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

ممتاز! يمكن أن يصل H1 و H2 إلى بعضهما البعض! هل هذا يعني أننا كذلك

انتهى؟ ليس تمامًا بعد … هناك المزيد أريد أن أعرضه لك:

SW2#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/15, Fa0/22, Fa0/23, Fa0/24
                                                Gi0/1, Gi0/2
50   Computers                        active    Fa0/2


بادئ ذي بدء ، إذا استخدمنا الأمر show vlan ، فلن نرى وصلة Fa0/14. هذا أمر طبيعي تمامًا لأن الأمر show vlan لا يعرض سوى الوصلات في وضع access وليس وصلات الـ trunk.

SW2#show interface fa0/14 trunk 
Port        Mode             Encapsulation  Status        Native vlan
Fa0/14      on               802.1q         trunking      1
Port        Vlans allowed on trunk
Fa0/14      1-4094
Port        Vlans allowed and active in management domain
Fa0/14      1,50
Port        Vlans in spanning tree forwarding state and not pruned
Fa0/14      50

يعد الأمر show interface trunk مفيدًا جدًا. يمكنك معرفة ما إذا كانت الوصلة في وضع trunk ، وما هو بروتوكول تغليف trunk الذي تستخدمه (802.1Q أو ISL) وما هي شبكة الـ Native VLAN والمسؤولة عن نقل الترفك الغير تابعة لاي VLAN . يمكننا أيضًا أن نرى أن الفيلانات من 1 - 4094 مسموح بها بالمرور على هذا الترنك.

يمكننا أيضًا أن نرى أن VLAN 1 و VLAN 50 فقط هي النشطة حاليًا. أخيرًا وليس آخرًا ، يمكنك رؤية ما اذا كانت شبكات VLAN في حالة توجيه في بروتوكول STP.

أريد أن أوضح لك شيئًا آخر حول وصلات الـ access و الـ trunk:

SW2#show interface fa0/2 switchport
Name: Fa0/2
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access

يمكن أن تكون الوصلة في وضع access أو في وضع ترنك. الوصلة أعلاه متصلة بـ H2 ويمكنك أن ترى أن وضع التشغيل هو "static access" مما يعني أنها في وضع access.
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
هذه هي واجهة الترنك المتصلة بـ SW1. يمكنك أن ترى أن وضع التشغيل هو وضع ترنك.
SW2(config-if)#switchport mode ?
  access        Set trunking mode to ACCESS unconditionally
  dot1q-tunnel  set trunking mode to TUNNEL unconditionally
  dynamic       Set trunking mode to dynamically negotiate access or trunk 
  private-vlan  Set private-vlan mode
  trunk         Set trunking mode to TRUNK unconditionally
إذا انتقلت إلى تهيئة الوصلة لتغيير وضع switchport ، يمكنك أن ترى أن لدي خيارات أكثر من access أو ترنك .  هناك أيضًا طريقة ديناميكية. لا تقلق بشأن الخيارات الأخرى في الوقت الحالي.
SW2(config-if)#switchport mode dynamic ?
  auto       Set trunking mode dynamic negotiation parameter to AUTO
  desirable  Set trunking mode dynamic negotiation parameter to DESIRABLE

يمكننا الاختيار بين المرغوب فيه ديناميكيًا تلقائيًا وديناميكيًا. سوف يكتشف السويش الخاص بنا تلقائيًا ما إذا كان يجب أن تصبح الوصلة منفذ access أم منفذ ترنك. إذن ما هو الفرق بين الديناميكي التلقائي والديناميكي المرغوب فيه؟ هيا نكتشف!
sw1-sw2



سوف ألعب مع وضع Switchport في SW1 و SW2 وسنرى ما ستكون النتيجة.
SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic auto
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic auto
أولاً ، سأغير كلا الواجهتين إلى تلقائي ديناميكي.
SW1(config-if)#do show interface f0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
SW2(config-if)#do show interface f0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access

وضعنا الإداري هو ديناميكي تلقائي ونتيجة لذلك لدينا الآن منفذ access.
SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic desirable
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic desirable
SW1#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
SW2#show interfaces fa0/14 switchport 
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk

بمجرد أن نغير كلا الوصلتين إلى مرغوب فيه ديناميكيًا ، ينتهي بنا الأمر مع ارتباط ترنك. ما رأيك سيحدث إذا قمنا بخلط أنواع switchport ؟ مثلا التلقائي الديناميكي على جانب واحد والديناميكي مرغوب فيه على الجانب الآخر؟ هيا نكتشف!
SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic desirable
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode dynamic auto
SW1#show interfaces f0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: trunk
يبدو أن السويش لديه رغبة قوية في أن يصبح ترنك. دعونا نرى ما يحدث مع مجموعات أخرى!
SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic auto
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode trunk
SW1#show interfaces f0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: trunk
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
ستفضل Dynamic auto أن تصبح منفذ access ولكن إذا تم تهيئة الوصلة الأخرى كترنك ، فسيصبح ترنك.
SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic auto
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode access
SW1#show interfaces f0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access

تكوين جانب واحد على أنه ديناميكي تلقائي والآخر كـ access والنتيجة سيصبح المنفذ access.
SW1(config)#interface fa0/14
SW1(config-if)#switchport mode dynamic desirable
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode trunk
SW1#show interfaces f0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
الوضع الديناميكي المرغوب فيه مع الترنك ستصبح الوصلة ترنك.

ماذا سيحدث برأيك إذا قمت بتعيين وصلة في وضع access والأخرى كترنك؟ لا تبدو فكرة جيدة ولكن دعنا نجرب حظنا:
SW1(config)#interface fa0/14
SW1(config-if)#switchport mode access
SW2(config)#interface fa0/14
SW2(config-if)#switchport mode trunk
SW1#show interfaces f0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: static access
Operational Mode: trunk
SW2#show interfaces fa0/14 switchport
Name: Fa0/14
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
SW1#
%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/14 VLAN1.
%SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/14 on VLAN0001. Inconsistent port type.
%SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/14 on VLAN0001. Port consistency restored.
بمجرد أن أقوم بتغيير وضع switchport ، أرى رسائل خطأ بروتوكول STP على SW1 . هو بروتوكول يعمل على السويشات لمنع الحلقات واللوب في شبكتنا.

 TrunkAccessDynamic AutoDynamic Desirable
TrunkTrunkLimitedTrunkTrunk
AccessLimitedAccessAccessAccess
Dynamic AutoTrunkAccessAccessTrunk
Dynamic DesirableTrunkAccessTrunkTrunk


هذا كل ما لدي من أجلك الآن حول الـ trunking. آمل أن يكون هذا مفيدًا لك. من الأفضل أن تجرب بعض هذه الأوامر على سويشك الخاص حتى تتعرف على الأوامر المختلفة. إذا استمتعت بهذا الدرس ، فالرجاء ترك تعليق أو مشاركته مع أصدقائك!

reaction:

تعليقات