القائمة الرئيسية

الصفحات

دورة CCNA 200-301 - الدرس التاسع والثلاثون (اعدادات الروت سويش في بروتوكول Spanning Tree)

دورة CCNA 200-301 - الدرس التاسع والثلاثون (اعدادات الروت سويش في بروتوكول Spanning Tree)

دورة CCNA 200-301 - الدرس التاسع والثلاثون (اعدادات الروت سويش في بروتوكول Spanning Tree)

في درس Per VLAN Spanning-Tree (PVST) ، أوضحت أننا نختار روت سويش لكل شبكة VLAN. في هذا الدرس ، سأعرض لك اعدادات مختلفة لتهيئة الروت.


الإعدادات

إليك التصميم الذي سنستخدمه في الشرح:

ثلاثة مفاتيح مثل المثلث Stp مثال


لدينا ثلاثة سويشات . على كل سويش، قمت باعداد ثلاث شبكات VLAN:

SW1, SW2 & SW3
(config)#vlan 10
(config)#vlan 20
(config)#vlan 30

وسنقوم باعداد الوصلات كترنك:

SW1, SW2 & SW3
(config)#interface range GigabitEthernet 0/0 - 1
(config-if-range)#switchport trunk encapsulation dot1q 
(config-if-range)#switchport mode trunk

دعونا نتحقق من معرفات الجسر للسويشات الثلاثة الخاصة بنا:

SW1#show spanning-tree bridge detail 
VLAN0001         
  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     5254.001a.935a
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0010         
  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     5254.001a.935a
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0020         
  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     5254.001a.935a
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0030         
  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     5254.001a.935a
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
SW2#show spanning-tree bridge detail
VLAN0001         
  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0010         
  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0020         
  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0030         
  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
SW3#show spanning-tree bridge detail
VLAN0001         
  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     5254.001d.e6bb
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0010         
  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     5254.001d.e6bb
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0020         
  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     5254.001d.e6bb
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
VLAN0030         
  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     5254.001d.e6bb
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

الأولوية لها قيمة افتراضية 32768 لذلك بدون اعداد أي شيء ، يكون عنوان MAC هو الفاصل. في حالتي ، SW2 هو الروت لجميع شبكات VLAN:

SW2#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     5254.0015.bc74
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/0               Desg FWD 4         128.1    P2p 
Gi0/1               Desg FWD 4         128.2    P2p 
SW2#show spanning-tree vlan 20

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    32788
             Address     5254.0015.bc74
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/0               Desg FWD 4         128.1    P2p 
Gi0/1               Desg FWD 4         128.2    P2p
SW2#show spanning-tree vlan 30

VLAN0030
  Spanning tree enabled protocol ieee
  Root ID    Priority    32798
             Address     5254.0015.bc74
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/0               Desg FWD 4         128.1    P2p 
Gi0/1               Desg FWD 4         128.2    P2p 

دعونا نرى ما يمكننا القيام به حيال ذلك. أرغب في اعداد شبكتي بحيث تبدو كالتالي:

تمتد شجرة الجسور الثلاثة


يمكننا تغيير الروت لكل شبكة (VLAN) باستخدام أمر spanning-tree. فيما يلي بعض الخيارات:
SW1(config)#spanning-tree vlan 10 ?    
  forward-time  Set the forward delay for the spanning tree
  hello-time    Set the hello interval for the spanning tree
  max-age       Set the max age interval for the spanning tree
  priority      Set the bridge priority for the spanning tree
  root          Configure switch as root
أعلاه ، نرى خيارين:
priority: يمكننا تغيير أولوية الروت يدويًا.
root: يمكننا تعيين السويش كروت مباشرةً.

ما الفرق بين هذه البارميترات؟ لنكتشف.

يقبل أمرspanning-tree vlan أيضًا نطاقات شبكات محلية ظاهرية (VLAN). على سبيل المثال 10-1

باراميتر الروت
سنبدأ بباراميتر الروت . دعونا نتحقق من خياراتنا:
SW1(config)#spanning-tree vlan 10 root ?
  primary    Configure this switch as primary root for this spanning tree
  secondary  Configure switch as secondary root
يمكنني اعداد السويش ليصبح روت أساسي أو روت ثانوي. لنجرب الأساسي:

SW1(config)#spanning-tree vlan 10 root primary
دعنا نتحقق مما إذا كان ذلك يعمل:

SW1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     5254.001a.935a
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     5254.001a.935a
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/0               Desg FWD 4         128.1    P2p 
Gi0/1               Desg FWD 4         128.2    P2p
في الإخراج أعلاه ، نرى أن SW1 هو الآن الروت لشبكة VLAN 10. أولوية SW1 هي الآن 24586.

يمكننا أيضًا اعداد سويش آخر ليصبح الروت "الثانوي". لنجرب ذلك على SW2:

SW2(config)#spanning-tree vlan 10 root secondary
دعنا نتحقق مما يفعله هذا الأمر:
SW2#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     5254.001a.935a
             Cost        4
             Port        1 (GigabitEthernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    28682  (priority 28672 sys-id-ext 10)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/0               Root FWD 4         128.1    P2p 
Gi0/1               Desg FWD 4         128.2    P2p
أعلاه ، نرى أن أولوية SW2 هي الآن 28682. في الحقيقة ، لا يوجد شيء اسمه الروت "الثانوي".
SW1#show running-config | include priority              
spanning-tree vlan 10 priority 24576
SW2#show running-config | include priority
spanning-tree vlan 10 priority 28672
الطريقة التي يعمل بها هذا هي أن السويش ينظر إلى أولوية الروت الحالي ثم يقلل من أولويته بحيث يصبح هو الروت.

باراميتر الأولوية
يمكننا أيضًا اعداد الأولوية يدويًا إليك مثال:
SW2(config)#spanning-tree vlan 20 priority ?
  <0-61440>  bridge priority in increments of 4096
لنجرب ذلك على SW2 لـ VLAN 20:

SW2(config)#spanning-tree vlan 20 priority 0
من خلال تعيين الأولوية بالقيمة 0 ، سيكون لدي أدنى أولوية ممكنة. دعنا نتحقق مما إذا كان SW2 هو الآن الروت لـ VLAN 20:

SW2#show spanning-tree vlan 20

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    20
             Address     5254.0015.bc74
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    20     (priority 0 sys-id-ext 20)
             Address     5254.0015.bc74
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/0               Desg FWD 4         128.1    P2p 
Gi0/1               Desg FWD 4         128.2    P2p
أعلاه ، نرى أن الأولوية الآن هي 0 (قيمة الأولوية 0 وقيمة الفيلان sys-id-ext هي 20 ). لنقم باعداد SW3 ليصبح الروت لشبكة VLAN 30:

SW3(config)#spanning-tree vlan 30 priority 0
هذا هو ناتج SW3:
SW3#show spanning-tree vlan 30

VLAN0030
  Spanning tree enabled protocol ieee
  Root ID    Priority    30
             Address     5254.001d.e6bb
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    30     (priority 0 sys-id-ext 30)
             Address     5254.001d.e6bb
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/0               Desg FWD 4         128.1    P2p 
Gi0/1               Desg FWD 4         128.2    P2p 

وكما نرى أعلاه ، SW3 هو الروت لـ VLAN 30. هذا كل ما في الأمر.

استنتاجات
لقد تعلمت الآن كيفية:
  • التحقق من الروت الحالي لكل شبكة (VLAN).
  • تعيين الروت باستخدام أمر spanning-tree:
    • باستخدام باراميتر root.
    • باستخدام باراميتر priority.
أتمنى أن تكون قد استمتعت بهذا الدرس. إذا كان لديك أي أسئله، رجاء أترك تعليقاً في الاسفل.
reaction:

تعليقات