القائمة الرئيسية

الصفحات

دورة CCNA 200-301 - الدرس الثالث والثلاثون (اصلاح مشاكل VLAN و الترنك)

دورة CCNA 200-301 - الدرس الثالث والثلاثون (اصلاح مشاكل VLAN و الترنك)

دورة CCNA 200-301 - الدرس الثالث والثلاثون (اصلاح مشاكل VLAN و الترنك)

في درس سابق شرحت بعض مشكلات الوصلات المحتملة التي يمكن أن نواجهها. بمجرد التحقق من تهيئة الوصلة بشكل صحيح وما زلت تواجه مشكلات ، فقد تكون المشكلة متعلقة بشبكات VLAN و الترنك. دعنا نلقي نظرة على بعض المشكلات الشائعة وكيفية حلها.


مشاكل في تخصيص الـ VLAN

ساستخدم هذه الشكل:

المضيف 1 التبديل 1 المضيف 2


H1 غير قادر على تنفيذ الأمر ping H2. لا توجد مشاكل مع الجهازين ، المشكلة تتعلق بالسويش. دعونا نرى ما يحدث عندما نجرب اختبار الاتصال:

C:>Documents and Settings>H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

جهازي الكمبيوتر غير قادرين على عمل ping بين بعضهما البعض (يا لها من مفاجأة!). لنفحص سريعًا ما إذا كانت هناك أية أخطاء في الوصلة:

SW1#show ip int brief
Interface           IP-Address      OK? Method Status                Protocol
FastEthernet0/1     unassigned      YES unset  up                    up      
FastEthernet0/3     unassigned      YES unset  up                    up

تبدو الوصلات بحالة جيدة ، ولا توجد أخطاء هنا. دعنا نتحقق من تخصيصات الـ VLAN:

SW1#show vlan 

VLAN Name                Status    Ports
---- -------------------------------- --------- -------------------------------
1    default             active    Fa0/1, Fa0/2, Fa0/4, Fa0/5
                                   Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                   Fa0/10, Fa0/11, Fa0/12,Fa0/13
                                   Fa0/14, Fa0/15, Fa0/16,Fa0/17
                                   Fa0/18, Fa0/19, Fa0/20,Fa0/21
                                   Fa0/22, Fa0/23, Fa0/24, Gi0/1
                                   Gi0/2
2    VLAN0002            active    Fa0/3

في هذه اللحظة ، من الجيد التحقق من معلومات VLAN. يمكنك استخدام الأمر show vlan للتحقق سريعًا من شبكة VLAN التي تنتمي إليها الوصلات.


كما ترى فإن الوصلة الخاصة بنا ليست في نفس شبكة VLAN. دعونا نصلح ذلك:

SW1(config)#interface fa0/3
SW1(config-if)#switchport access vlan 1

سننقل الوصلة Fa0/3 إلى VLAN 1 ، ليصبح كلا الجهازين في شبكة VLAN 1. لنحاول تنفيذ الأمر ping مرة أخرى:

C:>Documents and Settings>H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

تم حل المشكلة!


الدرس المستفاد: تأكد من أن الوصلة موجودة في شبكة VLAN الصحيحة.


مشاكل في وضع الـ Switchport

حان الوقت لحل مشكلة أخرى ، ساستخدم نفس الشكل:

المضيف 1 التبديل 1 المضيف 2


لقد تحققنا من عدم وجود أخطاء في الوصلة، وأن الوصلات تعمل بشكل طبيعي:

SW1#show ip interface brief 
Interface          IP-Address      OK? Method Status               Protocol
FastEthernet0/1     unassigned      YES unset  up                    up      
FastEthernet0/3     unassigned      YES unset  up                    up

الواجهات لا تظهر أي أخطاء. دعنا نتحقق من تعيينات الـ VLAN:

SW1#show vlan 

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/4, Fa0/5, Fa0/6
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12, Fa0/13,Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17,Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21,Fa0/22
                                                Fa0/23, Fa0/24, Gi0/1, Gi0/2
10   VLAN0010                         active    Fa0/1

أعلاه ، يمكنك أن ترى أن FastEthernet 0/1 موجود في VLAN 10 لكنني لا أرى FastEthernet 0/3 في أي مكان. فيما يلي الأسباب المحتملة:

  • هل هناك خطأ ما في الوصلة. لقد تحققنا من ذلك لأن حالة الوصلة up/up لذا يبدو أنها نشطة.
  • وضع الوصلة ليس access بل ترنك.


دعنا نتحقق من معلومات منفذ السويش:

SW1#show interfaces fa0/3 switchport 
Name: Fa0/3
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 10 (VLAN0010)
Trunking Native Mode VLAN: 1 (default)

نظرة سريعة على معلومات منفذ السويش توضح لنا ما نحتاج إلى معرفته. يمكننا تأكيد أن الوصلة fa0/3 في وضع ترنك وأن Native VLAN هي 1. وهذا يعني أنه عندما ترسل H2 حركة مرور ولا تستخدم علامات 802.1Q ، تنتهي حركة المرور الخاصة بنا في VLAN 1. فلنحول هذه الوصلة إلى وضع access:

SW1(config)#interface fa0/3
SW1(config-if)#switchport mode access 
SW1(config-if)#switchport access vlan 10
سنحول FastEthernet 0/3 إلى وضع access ونتأكد من أنها موجودة في VLAN 10. دعنا نتحقق من هذا:

SW1#show vlan id 10

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
10   VLAN0010                         active    Fa0/1, Fa0/3

كلتا الوصلتين نشطتان الآن وموجودتان في VLAN 10. يعد التحقق من وضع التشغيل فكرة جيدة أيضًا. دعونا نفعل ذلك:

SW1#show interfaces fa0/3 switchport | include Operational Mode 
Operational Mode: static access
تظهر الآن كوضع access. لنجرب أمر ping مرة أخرى:

C:>Documents and Settings>H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
الآن يمكنني إرسال ping من H1 إلى H2 ... تم حل المشكلة!

الدرس المستفاد: تأكد من أن الواجهة في وضع switchport الصحيح (وضع access أو ترنك).


مشاكل VACL (VLAN Access-List)
نفس جهازي الكمبيوتر ، نفس السويش ، ولكن المشكلة مختلفة:
المضيف 1 التبديل 1 المضيف 2


هذا السيناريو أكثر إثارة للاهتمام مع ذلك. أجهزة الكمبيوتر غير قادرة على اختبار الاتصال بين بعضها البعض ، لذا دعنا نتصفح قائمة الأخطاء "المحتملة" لدينا:
SW1#show ip interface brief 
Interface          IP-Address      OK? Method Status               Protocol
FastEthernet0/1     unassigned      YES unset  up                    up      
FastEthernet0/3     unassigned      YES unset  up                    up
الواجهات تبدو جيدة ، up / up وهو مانريد بالضبط. دعنا نتحقق من تعيينات VLAN:

SW1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active   Fa0/2, Fa0/4, Fa0/5, Fa0/6
                                               Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                               Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                               Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                               Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                               Fa0/23, Fa0/24, Gi0/1, Gi0/2
10   VLAN0010                         active   Fa0/1, Fa0/3
كلا الوصلتين في VLAN 10 لذا يبدو هذا جيدًا بالنسبة لي. قد يكون أمن المنفذ هو السبب. ربما؟
SW1#show port-security 
Secure Port  MaxSecureAddr  CurrentAddr  SecurityViolation  Security Action
                (Count)       (Count)          (Count)
---------------------------------------------------------------------------
---------------------------------------------------------------------------
Total Addresses in System (excluding one mac per port)     : 0
Max Addresses limit in System (excluding one mac per port) : 6144
فقط للتأكد ... لا يوجد أمن للمنافذ. هذهِ حالة مثيرة للاهتمام. حالة الوصلات up/up ، ونحن في نفس شبكة VLAN ولا يوجد أمن على المنافذ. أي شيء آخر يمكن أن يمنع حركة المرور؟ أنت تراهن أن هناك شي ما!
SW1#show vlan filter 
VLAN Map BLOCKSTUFF is filtering VLANs:
  10
قد لا يكون هذا شيئًا تفكر فيه على الفور ولكن يمكننا استخدام VACL (قائمة وصول VLAN) للسماح أو رفض حركة المرور داخل الـ VLAN. إذا كنت تعمل على تحرّي الخلل وإصلاحه في السويشات ، فهذا شيء يجب عليك النظر إليه إذا كان كل شيء آخر يبدو على ما يرام. في هذه الحالة ، يوجد VACL مرفق بـ VLAN 10 وهو يسبب المشكلة ، دعنا نفحصه:
SW1#show vlan access-map 
Vlan access-map "BLOCKSTUFF"  10
  Match clauses:
    ip  address: 1
  Action:
    drop
Vlan access-map "BLOCKSTUFF"  20
  Match clauses:
  Action:
    forward
يوجد رقمان متسلسلان ... 10 و 20. رقم التسلسل 10 يطابق قائمة الوصول 1 ويكون الإجراء هو إسقاط حركة المرور. دعنا نلقي نظرة على الموضوع:
SW1#show access-lists 
Standard IP access list 1
    10 permit 192.168.1.0, wildcard bits 0.0.0.255
لا داعي للارتباك بسبب تصريح السماح هنا. استخدام تصريح السماح في قائمة الوصول يعني أنه سوف "يتطابق" مع شبكة 192.168.1.0/24. يستخدم جهازي الكمبيوتر لدينا عناوين IP في هذا النطاق. إذا كانت تتطابق مع قائمة الوصول هذه ، فإن خريطة وصول VLAN ستسقط حركة المرور. دعونا نغيرها:
SW1(config)#vlan access-map BLOCKSTUFF 10
SW1(config-access-map)#action forward
دعنا نغير الإجراء لإعادة التوجيه ونرى ما إذا كان ذلك سيحل مشكلتنا:

C:>Documents and Settings>H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
ها نحن ذا ، عملية البينج تعمل الآن.

الدرس المستفاد: إذا كان كل شيء آخر يبدو على ما يرام ، فتأكد من عدم وجود VACL!


مشاكل الترنكينك
حتى الآن ، قمنا بفحص مشكلات VLAN على سويش واحد. عندما يتم التحقق من كل شيء مع شبكات VLAN الخاصة بك ويجب أن تمر حركة المرور بسويش واحد أو أكثر ، فقد ترغب في التحقق من القنوات. دعونا نلقي نظرة على هذا الشكل:

التبديل 1 2 مضيف 1 2 شبكة محلية ظاهرية 10


أعلاه لدينا سويشان ، خلف كل سويش يوجد جهاز في VLAN 10. للأسف لا تستطيع الاجهزة الوصول إلى بعضها البعض. من اين نبدأ؟

دعونا نتحقق من الوصلة على SW1 التي تتصل الجهاز أولاً:
SW1#show interfaces fa0/1
FastEthernet0/1 is up, line protocol is up (connected)
SW1#show interfaces fa0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 10 (VLAN0010)
SW1#show port-security interface fa0/1
Port Security : Disabled
الوصلة تعمل ، وهي switchport وتم تخصيصها لشبكة VLAN 10. وهذا يبدو جيدًا حتى الآن. لم يتم تمكين أمان المنفذ ، لذلك لا داعي للقلق بشأنه. لنفعل نفس الفحص على SW2:
SW2#show interfaces fa0/2
FastEthernet0/2 is up, line protocol is up (connected)

SW2#show interfaces fa0/2 switchport
Name: Fa0/2
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 10 (VLAN0010)
SW2#show port-security interface fa0/2
Port Security : Disabled
تحققت من نفس الأشياء على SW2. الوصلة تعمل وتم تخصيصها في VLAN 10.

في هذه اللحظة ، نعلم أن وصلات أجهزة الكمبيوتر قد تم تهيئتها بشكل صحيح. الأن يمكننا القيام بأمرين:
  • قم بتوصيل كمبيوتر آخر بـ SW1 وقم بتعيينه في VLAN 10. لكي تعرف ما إذا كان يمكنك الاتصال بين أجهزة الكمبيوتر في VLAN 10 عندما تكون متصلة بالسويش نفسه. افعل الشيء نفسه على SW2.
  • تحقق من الوصلة بين SW1 و SW2.

سأركز على الوصلة بين SW1 و SW2 لأن هناك الكثير يمكن أن يحدث بشكل خاطئ هناك! لنلقي نظرة:
SW1#show interfaces fa0/15
FastEthernet0/15 is up, line protocol is up (connected)
SW2#show interfaces fa0/15
FastEthernet0/15 is up, line protocol is up (connected)
لا تظهر الوصلات أية مشاكل ، حان الوقت للتحقق من معلومات switchport:
SW1#show interfaces fa0/15 switchport 
Name: Fa0/15
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)

SW1 في وضع ترنك ويستخدم بروتوكول التغليف ISL. ماذا عن SW2؟
SW2#show interfaces fa0/15 switchport 
Name: Fa0/15
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)Trunking Native Mode VLAN: 1 (default)
SW2 أيضًا في وضع ترنك ولكنه يستخدم بروتوكول التغليف 802.1Q. كن على دراية أن الوضع الإداري الافتراضي (وفقًا لطراز السويش) قد يكون ديناميكيًا تلقائيًا. ستصبح الوصلتان اللتان تعملان في الوضع التلقائي الديناميكي بمثابة منافذ اكسس. من الأفضل تغيير الواجهة إلى وضع ترنك بنفسك. في حالتنا ، تكون كلتا الوصلتين متصلتين ، وهذا أمر جيد ولكن لدينا بروتوكول تغليف غير متطابق. دعونا نصلح ذلك:

SW1(config)#interface fa0/15
SW1(config-if)#switchport trunk encapsulation dot1q
سنقوم بتغيير نوع التغليف بحيث يستخدم كلا السويشين بروتوكول 802.1Q. هل هذهِ هي المشكلة؟
C:>Documents and Settings>H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
تم حل المشكلة! نجحت عملية البينج.

الدرس المستفاد: تأكد من استخدام نفس بروتوكول التغليف عند تهيئة وصلات الترنك.

مشكلة الـ VLANs المسموحة من قبل منفذ الترنك
دعونا نلقي نظرة على مشكلة أخرى في الترنك , سنستخدم نفس الشكل:

التبديل 1 2 مضيف 1 2 شبكة محلية ظاهرية 10


افترض أننا تحققنا من أن العناصر التالية لا تسبب أي مشاكل:
  • الوصلات (السرعة / الدوبلكس)
  • أمن المنافذ.
  • تهيئة منفذ السويش (التحقق من تخصيص الـ VLAN ، والوصلة في وضع اكسس).

وبالرغم من ذلك . لا تزال اجهزتنا غير قادرة على التواصل مع بعضها البعض:

C:>Documents and Settings>H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
دعونا نتحقق من الترنك بين السويشات:
SW1#show interfaces fa0/15 switchport 
Name: Fa0/15
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
SW2#show interfaces fa0/15 switchport 
Name: Fa0/15
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
سأتحقق من أن كلا الوصلتين في وضع ترنك وأننا نستخدم نفس بروتوكول التغليف (802.1Q). لا توجد مشاكل هنا. أي شيء آخر يمكن أن يسبب خطأ مع هذا رابط الترنك هذا؟
SW1#show interfaces fa0/15 trunk 

Port        Mode             Encapsulation  Status        Native vlan
Fa0/15      on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/15      20
SW2#show interfaces fa0/15 trunk 

Port        Mode             Encapsulation  Status        Native vlan
Fa0/15      on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/15      20
قد يكون الترنك جاهزًا للعمل ولكن هذا لا يعني أنه يُسمح لجميع شبكات VLAN بالمرور من خلاله. في المثال أعلاه ، يمكنك أن ترى أن VLAN 20 هي المسموح به فقط. دعونا نصلح ذلك:
SW1(config)#interface fa0/15
SW1(config-if)#switchport trunk allowed vlan all
SW2(config)#interface fa0/15
SW2(config-if)#switchport trunk allowed vlan all
دعونا نسمح لجميع شبكات VLAN بالمرور عبر رابط الترنك. لنجرب اختبار البنج مرة أخرى:
C:>Documents and Settings>H1>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128
Reply from 192.168.1.2: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
يمكن الآن لشبكة VLAN 10 بالمرور عبر رابط الترنك بين السويشين. ونتيجة لذلك تنجح عملية الاتصال بين أجهزة الكمبيوتر … مشكلة أخرى تم حلها!

الدرس المستفاد: تحقق دائمًا مما إذا كان الترنك يسمح بجميع شبكات VLAN أم لا.

هذا كل ما لدي الآن ، وآمل أن يكون هذا مفيدًا في العثور على مشكلات VLAN ومشكلات الترنك ذات الصلة وإصلاحها على سويشاتك. إذا كان لديك أي أسئلة ، فلا تتردد في ترك تعليق!


reaction:

تعليقات